tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
(pascal или delphi) в заданном
(pascal или delphi) в заданном массиве a(n) положительные элементы уменьшить вдвое, а отрицательные заменить на значения их индексов.
smolyarrrovav
1 29.06.2019 23:10
3
Ответы
МЫСЛИТЕЛЬ512
23.07.2020 18:26
Var a:array of real;
n,an:integer;
begin
randomize;
writeln('Введите размерность массива');
readln(n);
n:=n+1;
setlength(a,n);
for an:=1 to n-1 do
begin;
a[an]:=random(10);
if a[an]>0 then a[an]:=a[an]/2 else a[an]:=an;
write (a[an],',');
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Asil1231
30.11.2020 05:43
При выключении компьютера информация исчезает из...
Natasatana
15.08.2019 01:10
12 написать,можно скопировать с интернета,небольшой реферат 2 в 1) на тему: операционные системы и программы,составляющие операционную систему,и программные оболочки)...
kseniya04ok
15.08.2019 01:10
Янта попросили принести чайник и чашки к чаю.дай имена трём чашкам...
Ele4ka17
27.10.2019 17:10
Найти количество трехзначных чисел, которые при делении на 26 остаток 11 написать на языке паскаль...
алгебра107
27.10.2019 17:02
Информатика c++ 8 класс 2 (написать программу)...
mironmashstem
25.02.2021 16:12
27. По каналу связи каждую секунду передаётся положительное целое число, все числа не превышают 10 000. Передача происходит мгновен-но. Необходимо вычислить максимальное...
Nyushata
25.02.2021 16:11
Составьте программу для вычисления значения выражения: 1,5 × 2,5 × 3,5 ... × 15,5PascalABC.NET ...
batyka228
15.07.2019 04:30
Среди моих друзей четверо играют в футбольной команде пятеро волейбольной трое из них играют футбольный волейбольный командах сколько всего моих друзей играет футбольный...
ankateren
15.07.2019 04:30
Неопределенная форма глагола отправится...
goldin1337
15.07.2019 04:30
Напишите фонетический разбор слова чужой....
Популярные вопросы
надо ответить на два вопроса и дать ответ Yes или No...
2
Найдите значение переменнойS,если N=7 Начало Ввод N S:=1 i=1,N; шаг...
1
Доробити задачу по фізиці на тему Тертя.Сила тертя....
2
Сост диолог на тему Подарок маме своим руками (Долог с другом типо...
3
задание 4. закончить предложение. а) чем меньше температура газа,тем...
1
Предложение When most people think of animal shelters, they think...
3
My little world Read the dialogue and answer the questions. »Who jumped...
2
сделать таблицу по географии 9 класс Северо-Западный экономический...
2
Ангилиский 6 класс 3 четверг...
2
Напишите уравнения реакций, осуществляющих химический цикл. CH4 O2...
2
n,an:integer;
begin
randomize;
writeln('Введите размерность массива');
readln(n);
n:=n+1;
setlength(a,n);
for an:=1 to n-1 do
begin;
a[an]:=random(10);
if a[an]>0 then a[an]:=a[an]/2 else a[an]:=an;
write (a[an],',');
end;
end.