tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Pascal, цикл while или repeat
Pascal, цикл while или repeat ввести число. найти наибольшую цифру в записи числа.
Vafelka225
1 21.08.2019 04:30
7
Ответы
mariamarkova609
05.10.2020 08:37
Var
n : integer;
max: byte;
begin
write ('Введите число: ');
readln (n);
n:=abs (n);
while n>0 do
begin
if (n mod 10)>max then max:=n mod 10;
n:=n div 10;
end;
write ('Макс. цифра - ', max);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Arinakap22
15.02.2021 16:01
Если у клетки сверху есть стена сверху и у клетки снизу есть стена снизу-закрась исходную клетку.Остановиться в исходной клетке...
Тупой7А
15.02.2021 15:53
З метою збільшення товарообігу на оптовій базі встановлені торгові знижки. Якщо певний вид товару купується на суму більш ніж 10 тис. грн, призначається знижка. Розрахувати...
Yulia221
04.06.2019 18:20
Напишите код для html страницы. страница должна включать в себя шапку, три столбца, картинку и гиперссылку....
masaberegovenko
29.05.2019 02:40
30 ! составьте программу ,которая формирует массив ,содержащий 8 случайных целых чисел, принадлежащих промежутку [0; 5] ,и преобразует элементы массива по следующему...
oli21
29.05.2019 02:40
Написать программу в c++ дан одномерный массив x из n элементов. найти порядковый номер первого по счёту положительного элемента с чётным порядковым номером. все...
gaibog
21.08.2020 13:10
Of karandro 8 desteden bahadie 8 kara noasmi bohodeyoxsa 9 detta...
54535446
05.09.2021 16:52
52/7 умножить 3/2 по брацки...
РенаКОСЫРЕВА
05.09.2021 16:52
Which forces are contact forces, and which are non contact forces?...
aleksandrakova4
05.09.2021 16:52
Ұгымдық мағыналық сөздерге 15 мысалдар...
Хрустяня
05.09.2021 16:52
закодируйте соообщения,используя правила кодирования ,приведенных в предыдущем задании : a) информатика b)сообщение найдите сведения и подготовьте сообщение о кодирования...
Популярные вопросы
1)книга стоила 250 рублей. затем сделали скидку 6%. сколько рублей...
2
Морфологический разбор слова водичкой...
3
Не большое сочинение на тему мой любимый герой...
2
Современные теории эволюции примеры...
1
Составить текст на тему осень во дворе...
3
Напишите рассказ описывающий ночное время суток....
3
Нок (18; 45) нод (18; 45) нок (30; 40) нод (30; 40)...
3
Примеры из кинофильмов,,художественной , интернет-ресурсов как...
1
Найти производную функции: 1)f(x) =(4-3x)^7 2) f(x) =x^3lnx 3)...
2
F(x)=3x⁴+5x³+4x²-2 найти производную функцию...
1
n : integer;
max: byte;
begin
write ('Введите число: ');
readln (n);
n:=abs (n);
while n>0 do
begin
if (n mod 10)>max then max:=n mod 10;
n:=n div 10;
end;
write ('Макс. цифра - ', max);
end.