Pascal abcнапишите программу, которая определяет правильность записи целого числа в восьмеричной системе счисления. формат входных данных на вход программы поступает символьная строка. формат выходных данных программа должна вывести ответ 'yes', если строка представляет собой правильную запись целого числа в восьмеричной системе счисления, и 'no', если запись ошибочна.

КилоЛеденцов КилоЛеденцов    3   22.08.2019 16:20    4

Ответы
xXDenchykXx1 xXDenchykXx1  05.10.2020 12:58
Var value, error: integer;
begin
var s:=readstring ('Введите строку: ');
val (s, value, error);
if (error<>0) or ('9' in s) or ('8' in s) then write ('NO') else write ('YES');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика