tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Pascal abc составить программу
Pascal abc составить программу для нахождения s дано натуральное число n. найти сумму s=1- 1/5 + 1/9 - 1/+ (n-слагаемых) !
динька2
1 13.09.2019 05:50
2
Ответы
sir228qwerty
07.10.2020 11:12
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('n=');
Writeln(Range(0,n-1).Select(i->1/(i.IsEven?4*i+1:-(4*i+1))).Sum)
end.
Пример
n= 13
0.876761945581588
для Pascal ABC (проверить негде, проект закрыт в 2004 году)
var
i,n,z:integer;
x,s:real;
begin
Write('n='); Read(n);
s:=0; z:=1;
for i:=0 to n-1 do begin
x:=1/(4*i+1);
s:=s+x*z;
z:=-z
end;
Writeln(s)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
ksun2003
15.06.2019 06:50
Кто работает в поезде? ы заполни пропуски в списке. 1.электровоз 1.1. 1.2. машиниста 2.пассажирские вагон 2.1.первый вагон 2.1.1.начальник поезда 2.1.2. 2.1.3. 2.1.4....
lizstys
11.11.2020 20:58
Запишите 32-битный IP-адрес: 01000000 10000001 11111111 00100000 в виде четырёх десятичных чисел, разделённых точками....
1ирочка1
04.10.2019 03:30
Заполните массив из 10 элементов случайными числами из диапазона [0,50].выведите массив на экран. местами в массиве значение второго и пооследнего элементов.выведите...
89267989725
04.10.2019 03:30
Из любой системы в любую.напишите программу , которая переводит целое число n(1 =|n| 10^9) счисления с основанием к(2 =к =36) в систему счисления с основанием м(2...
snikola97
04.10.2019 03:30
Для чего полезен компьютерный сленг?...
evgen22region
07.10.2021 21:36
2. Возможно ли с графического исполнителя алгоритмов Чертёжник нарисовать: прямоугольник, треугольник, пятиконечную звезду, буквы «Н», «Х», «Р», «М»? Аргументируйте...
Роднойязык11
05.10.2019 11:30
Найди значение выражений b*8 и b: 8, если d=7 200; d=64 00; d=96 000...
anytabudanova
05.10.2019 11:30
При каком значение b выражение 3+2b и 2b+7 равны? а) при любомв) -1 с) 3/7д) ни при каком...
jillikati
05.10.2019 11:30
Вставьте вместо точек слова! сделать до завтра.pair work. ask your friend about his/her birthday party. a. when is your birthday? b. it is a. do you invite your friends...
marselk2
05.10.2019 11:30
Вопросы по поэме некрасова кому на руси жить хорошо 1.какова тема поэмы некрасова кому на руси жить хорошо 2.перечислите главных героев поэмы.дайте им кратакую зарактеристику...
Популярные вопросы
Соберите материал об учёных, внёсших вклад в развитие науки Азрбайджана...
2
Обчисліть: а) масу, б)кількість речовини сірки, в)число молекул...
1
3. - Your friends enjoy swimming, __ ? A) do theyB) does heC)...
2
Решите неравенство. x+10 3x^2...
1
В треугольнике ABC к стороне AB=12 см опущена высота, длина которой...
3
- Вычислить значение выражения: 13°25 -4 - 27°23...
2
Вычислите значение выражения 10100(1/101*104+1/104*107+...+1/161*164)...
1
Сколько нужно джоулей тепла для обогрева квартиры, например, 51...
2
нужно решить с новым годом всех...
1
Вычислить значение выражения: 38°25 - 2•17°41 + 29°16...
1
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('n=');
Writeln(Range(0,n-1).Select(i->1/(i.IsEven?4*i+1:-(4*i+1))).Sum)
end.
Пример
n= 13
0.876761945581588
для Pascal ABC (проверить негде, проект закрыт в 2004 году)
var
i,n,z:integer;
x,s:real;
begin
Write('n='); Read(n);
s:=0; z:=1;
for i:=0 to n-1 do begin
x:=1/(4*i+1);
s:=s+x*z;
z:=-z
end;
Writeln(s)
end.