Pascal abc. напишите программу! "дан массив размера n. вывести последний нечетный элемент массива и его номер"

lolkek142 lolkek142    2   08.10.2019 08:10    13

Ответы
dmtrysuraev dmtrysuraev  22.01.2024 10:03
Хорошо, давайте решим задачу по написанию программы на языке Pascal.

Для начала, нам понадобится задать массив и его размерность. Давайте создадим переменные для этого:

var
n, i, lastOdd, lastOddIndex: integer;
arr: array[1..100] of integer;

Здесь:
- n - переменная для хранения размерности массива, то есть количество элементов
- i - переменная для использования в цикле
- lastOdd - переменная для хранения значения последнего нечетного элемента
- lastOddIndex - переменная для хранения индекса последнего нечетного элемента
- arr - массив, в котором будем хранить элементы

Следующим шагом, нам нужно предложить пользователю ввести размерность массива и его элементы. Для этого используем следующий код:

writeln("Введите количество элементов в массиве:");
readln(n);
writeln("Введите элементы массива:");

for i := 1 to n do
begin
readln(arr[i]);
end;

Теперь у нас есть массив arr с заданной размерностью n и введенными элементами.

Далее, мы проходим по массиву в обратном порядке и ищем последний нечетный элемент:

lastOdd := -1; // Инициализируем переменную последнего нечетного элемента значением -1 (это значение будет оставаться таким, если в массиве не будет нечетных элементов)

for i := n downto 1 do
begin
if arr[i] mod 2 <> 0 then // Проверяем, является ли текущий элемент нечетным
begin
lastOdd := arr[i]; // Присваиваем значение текущего элемента последнему нечетному
lastOddIndex := i; // Запоминаем индекс последнего нечетного элемента
Break; // Прерываем цикл, так как мы уже нашли последний нечетный элемент
end;
end;

Наконец, выводим результат на экран:

writeln("Последний нечетный элемент:", lastOdd);
writeln("Его номер:", lastOddIndex);

Вот и всё! Мы написали программу на языке Pascal, которая находит последний нечетный элемент массива и выводит его значение и индекс на экран.

Если у вас возникнут вопросы, не стесняйтесь задавать. Я готов помочь вам понять решение еще лучше!
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика