Pascal abc без random и всяких crt 1) вводится строка, состоящая только из строчных латинских букв. найти какая буква в строке встречается максимальное количество раз. формат ввода строка s формат вывода буква и количество раз, которое эта буква встречается в строке. примеры: выводит j - 7 2) напишите программу, которая находит в массиве максимальную последовательность убывающих элементов формат ввода первая строка содержит размер массива n. во второй строке через пробел n чисел – элементы массива. гарантируется, что 1 < n ≤ 10000. элементы массива - целые числа, не превышающие по модулю 1000 формат вывода одно число: максимальное количество убывающих элементов пример: 5 и 1 2 3 4 5 вывод 0 5 и 1 3 2 1 4 вывод 3

Nastya77777778 Nastya77777778    2   28.08.2019 08:00    0

Ответы
yliana63 yliana63  06.10.2020 00:12
Var C:array['a'..'z'] of integer;
    S:string;
    i,Max:integer;
    j:char;
Begin
Read(S);
For i:= 1 to Length(S) do
    C[S[i]]:=C[S[i]]+1;
Max:=C['a'];
For j:= 'b' to 'z' do
    if Max<C[j] then Max:=C[j];
WriteLn(Max)
End.

Var
   A:array[1..10000] of integer;
   i,k,Max:integer;
Begin
ReadLn(i);
For i:= 1 to i do
    Read(A[i]);
k:=0;
Max:=0;
For i:= 1 to i-1 do
    if A[i]>A[i+1] then k:=k+1
    else if k>Max then
            Begin
            Max:=k;
            k:=0;
            End;
if Max=0 then WriteLn(0)
else WriteLn(Max+1)
End.
ПОКАЗАТЬ ОТВЕТЫ
инна1382 инна1382  06.10.2020 00:12
Var a: array[1..255] of integer;
    b: array[1..10000] of integer;
    s: string;
    i,mx,tek,ind,n: integer;
begin
// задание 1
  write('строка: ');  readln(s);
  mx:=0; ind:=0;
  for i:=1 to 255 do a[i]:=0;
  for i:=1 to length(s) do
  if s[i] in ['a'..'z'] then inc(a[ord(s[i])]);
  for i:=ord('a') to ord('z') do if a[i]>mx then
  begin
    mx:=a[i];
    ind:=i;
  end;  
  writeln('наиболее часто встречается буква: ',chr(ind),' - ',mx);
// задание 2
  write('N = ');  readln(n);
  mx:=0; tek:=0;
  read(b[1]);
  for i:=2 to n do
  begin
    read(b[i]);
    if b[i]<=b[i-1] then inc(tek)
    else
    begin
      if tek>mx then mx:=tek;
      tek:=0;
    end;  
  end;
  if mx>0 then writeln(mx+1)
  else writeln(0);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика