Огэ 20.2. паскаль. требовалось написать программу, определяющую количество трехзначных чисел, кратных 3. я написал: if (x> 99) and (x< 999)and (x mod = 0) then i: = i+1 снимут ли за (x< 999) ,а не (x< 1000)

theonestop1234 theonestop1234    2   04.06.2019 09:29    0

Ответы
лола268 лола268  05.07.2020 12:24

Var

A:array[1..3]of integer;

P,k:integer;

Begin

P:=3;

While p>0 do begin

If a[p]<9 then begin

Inc(a[p]);

P:=3;

If (a[1]>0)and((a[1]*100+a[2]*10+a[3]) mod 3 = 0 then inc(k);

End

Else begin

A[p]:=0;

P:=p-1;

End;

End;

Writeln(k);

End.

Попробуй эту прогу

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика