tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Одномерный массив. найти сумму
Одномерный массив. найти сумму тех элементов которые без остатка делиться на 2 (pascal).
Uuuuuu2006
3 16.08.2019 21:50
1
Ответы
liteops04
08.09.2020 17:49
Const n=20;
var
s,i: integer;
var a: array[1..n] of integer;
begin
writeln ('Исходный массив');
for i:=1 to n do begin
a[i]:=random(100);
write (a[i]:3);
if a[i] mod 2 =0
then s:=s+a[i];
end;
writeln;
writeln ('Сумма четных элементов = ',s);
end.
Результат:
Исходный массив
81 44 47 62 51 94 32 42 41 83 75 14 18 35 7 97 83 51 71 57
Сумма четных элементов = 306
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Emro
09.07.2019 12:30
Сколько байт информации занимает на диске 1 секунда стереозаписи если частота дискретизации 44032 гц, при 16 битном кодировании, а также определить сколько занимает...
lolmrminilotr
09.07.2019 12:30
Вмодели rgb для кодирования 1 пикселя используется 3 байта, фотографию размеров 2048*1536 сохранили в виде несжатого файла. определите размер получившегося файла....
airamoon
06.05.2020 12:27
До ть будь ласка розв язати ребус ! ів...
ivanovasvetak
21.05.2019 17:41
Начертить звезду в чертежнике в программе ,,кумир,,...
fafgames72
21.05.2019 17:42
Сделайте программу по блок схеме на c++...
oliaputliar
16.07.2019 10:30
Составить программу вычисления, w = b + a - сумма положительных элементов массива; b – номер наименьшего элемента массива; c - количество элементов массива кратных...
Kisa550
16.07.2019 10:30
Каким образом можно увеличить расстояние между абзацами не меняя расстояние между строками в самом абзаце...
llll23
28.04.2020 13:27
1. Как можно создавать модели в SketchUp? 2. Функция кнопки ВРАЩЕНИЕ? 3. Функция кнопки ПРЕДЫДУЩИЙ ВИД? ...
ВолшебнаяПринцесса
28.04.2020 13:20
решить НУЖНО. Записать алгоритм, блок-схему и программу....
danayamirnaya
28.04.2020 13:26
Матрицу размером 5*5 заполнить случайными двоичными числами (0,1)....
Популярные вопросы
Вычислить средне суточную и суточную амплитуду за 15 марта (9часов,13часов,18часов,21час)...
2
Разложение многочлена на множитель группировки; 4(c+3)+x(c+3)...
1
1)внешний угол треугольника равен 140, в внутренние углы, не...
2
К40 г раствора соли прибавили 10 г воды вычислите массовую долю...
2
Решите уравнения: 1) -3,2+x=-9 2)x-5 3\4(дробью)=-12 1\6(дробью)я...
3
Мать с сыном слушали музыку в предложении подлежащее выражено...
3
Сочинение рассуждение на тему как я буду определять спряжение...
2
Какие группы крови возможны у детей, если у матери 1 группа крови,...
3
1.наследственно глухонемой мужчина женился на женщине с нормальным...
3
С: масса 5 маленьких коробочек и 2 больших коробок конфет ровна...
3
var
s,i: integer;
var a: array[1..n] of integer;
begin
writeln ('Исходный массив');
for i:=1 to n do begin
a[i]:=random(100);
write (a[i]:3);
if a[i] mod 2 =0
then s:=s+a[i];
end;
writeln;
writeln ('Сумма четных элементов = ',s);
end.
Результат:
Исходный массив
81 44 47 62 51 94 32 42 41 83 75 14 18 35 7 97 83 51 71 57
Сумма четных элементов = 306