tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Одномерные массивы. дан массив
Одномерные массивы. дан массив натуральных чисел, состоящий из n элементов. найти сумму элементов массива, кратных данному числу к. (паскаль)
LymarIvan
1 08.06.2019 08:10
0
Ответы
умник20056
07.07.2020 15:28
Const n = 10;
var a :array [1..n] of integer; k, sum :integer;
begin
readln(k); for i:= 1 to n do readln(a[i]); sum:= 0; for i:= 1 to n do if a[i] mod k = 0 then sum:= sum +a[i]; writeln(sum);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
akr999
30.07.2019 06:40
Не знаю, как написать, важно сделать эту . , . напишите программу, вычисляющую факториал числа. факториал числа n (обозначается n! ) - произведение всех натуральных...
ImVadimka
27.04.2021 11:33
Сделайте гиперссылку на слово рисунок...
sashka2006123
27.04.2021 11:33
1. Недостаток бесплатного хостинга: а) Коммерческая реклама от постовщика услуги б) отсутствие вариантов размещения в) доменное имя 2. Как называют схему страницы, на...
mashuna1
18.02.2021 10:25
Что такое приводная платформа...
cerkasovae50
18.02.2021 10:24
Составьте программу вычисления у по заданному х. y=-3х, х 0 х+5, x20 Пример входных данныхx=-5X=2...
rtrc2002
03.01.2022 16:02
Что является предметом труда животноводства?...
anastasiaruabenko
03.01.2022 16:01
4. Укажите качественное прилагательное, А) свинцовый В)ежовый C) ситцевый D) свободный E) морской...
марина1925
03.01.2022 16:01
(58-31):3-2+(58-16):6+8*5-(60-42):3+9*2 реши выражения...
tiomashash
03.01.2022 15:58
X+1/3=-7/5 буду очень благодарна) дам за это )...
mir32
03.01.2022 15:58
Задание 1. 1. Прочитайте слова и словосочетания: (не)доумевать, лыка (не)вяжет, (не)домогать, далеко (не)уедешь, калачом (не)заманишь, (не)истовствовать, руки (не)доходят,...
Популярные вопросы
Переведите на румынский язык нужно классический стиль одежды - это...
1
Посмотрите вечером на звездное небо.составьте текст на тему .( предложений.)...
3
Вынесите общий множитель за скобки: 9a²b² - 12ab³ = ? 20x³y² + 4x²y...
3
Мотоциклист в первый день был в пути 5ч,а во второй 3ч.всего он проехал...
2
Расставьте события в хронологическом порядке: 1.возникновение государства...
3
Найдите все тропы в стихотворении пушкина зимняя дорога сквозь волнистые...
2
Люди что такое сочинение надо по литре...
2
Сочинение на тему: человек и компьютер....
3
Напишите 3 слова с парными согласными и 3 слова с безударными в корне...
2
Зашифруй слово еж. составить алгоритм расшифровки буквы...
1
var a :array [1..n] of integer; k, sum :integer;
begin
readln(k); for i:= 1 to n do readln(a[i]); sum:= 0; for i:= 1 to n do if a[i] mod k = 0 then sum:= sum +a[i]; writeln(sum);
end.