Нужно составить программу, которая сможет вывести число, месяц и день недели, которые наступят через k дней, начиная с первого января 2008 года. напомним, что это был вторник. язык : паскаль. целое число k (0 < = k < = 1000) пример: входа: | выхода: 0 | tuesday, 01.01 5 | sunday, 06.01

dimabashlik3857 dimabashlik3857    3   09.07.2019 06:20    5

Ответы
fghzghvyvvfsgv fghzghvyvvfsgv  16.09.2020 22:18
// Я очень, невероятно не люблю изобретать велосипеды
//Поэтому воспользуемся уже встроенным типом DataTime
//Pascal ABC.NET Версия 2.2 Сборка 790
uses system;
var k:integer;
startSys:DateTime; //сабж
m,d:string;
begin;
readln(k);
startSys:=startSys.AddYears(2007); //добавляет года к старту, отсчёт от 1
startSys:=startSys.AddDays(k); //добавляет кол-во дней
//тип сам определяет високосный год или нет
writeln(startSys.DayOfWeek,', ',startSys.Day,'.',startSys.Month); //вывод
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика