Нужно решение буду завтра итоговая контрольная: дан массив чисел d[i],в котором 7 элементов.найти сумму четных элементов массива,и вычеслить среднее арифметическое всех элементов массива. буду признателен, пишем на паскале, если можно напишите программу, или скиньте скрин! жду

gotov2344433332 gotov2344433332    2   29.07.2019 19:40    0

Ответы
ttttrrrrtttr ttttrrrrtttr  27.09.2020 14:24
Const
n = 7;
var a: array [1..n] of integer; i, m0, m1: integer;
 begin
  m0:=0; m1:=0;
  writeln('Массив -->');
  for i:= 1 to n do readln(a[i]);
   for i:= 1 to n do begin
    m0:=m0+a[i];
    if a[i] mod 2 = 0 then m1:= m1+a[i];
  end;
 writeln('Cумма четных элементов массива: ',m1);
 writeln('Cреднее арифметическое всех элементов массива: ',m0/n);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика