Нужно написать программу.введите с клавиатуры 2 числа а и в,если числа не равны,то замените каждое из них на 0 и выведите результатом на экран.если они равны,то найдите и выведите удвоенную сумму этих чисел

ezdinaa ezdinaa    2   18.03.2019 10:50    10

Ответы
kirakoveduard kirakoveduard  25.05.2020 23:18

var a,b:integer;

begin

readln(a,b);

if a<>b then begin a:=0; b:=0; writeln(a,' ',b); end else writeln(2*(a+b));

end.

ПОКАЗАТЬ ОТВЕТЫ
Olgaekolesnik Olgaekolesnik  25.05.2020 23:18

var
  a, b: real;  //Инициализируем 2 действительных переменных

begin
  writeln('Введите 2 числа');
  readln(a, b);  //Вводим 2 числа
  if a <> b then   {Если числа не равны, то присваиваем переменным нули и печатаем их, иначе печатаем удвоенную сумму этих чисел}
  begin
    a:= 0;
    b:= 0;
    writeln('a = ', a, ', b = ', b);
  end
  else writeln('2 * (', a, ' + ', b, ') = ', 2 * (a + b));
end.

Если все правильно, отметь решение как лучшее)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика