Нужно написать программу в pascal.. даны названия 3 городов (любых). вывести на экран самое длинное и самое короткое название.

НикаНик1111 НикаНик1111    1   31.07.2019 01:50    5

Ответы
казактілі3 казактілі3  07.09.2020 23:27
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
  var a:array[1..3] of string;
  var l:array[1..3] of integer;
  for var i:=1 to 3 do begin
    Write('Город ',i,': '); Readln(a[i]);
    l[i]:=Length(a[i])
    end;
  var imin:=1; var imax:=1;
  for var i:=2 to 3 do begin
    if l[i]<l[imin] then imin:=i;
    if l[i]>l[imax] then imax:=i
    end;
  Writeln('Самое длинное название- ',a[imax]);
  Writeln('Самое короткое название- ',a[imin])
end.

Тестовое решение
Город 1: Москва
Город 2: Минск
Город 3: Киев
Самое длинное название- Москва
Самое короткое название- Киев
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика