, Нужно написать программу с рекурсивной функцией для умножения двух чисел А*В используя только операцию сложения.
С++

listik194 listik194    3   21.12.2021 15:36    4

Ответы
Pomogatorr Pomogatorr  21.12.2021 15:40

#include <iostream>

double multiply(double num1, double num2) {

   if (num2 > 0) return num1 + multiply(num1, num2 - 1);

   else if (num2 < 0) return -num1 + multiply(num1, num2 + 1);

   return 0;

}

signed main() {

   

   //2.2 * 2

   std::cout << multiply(2.2, 2) << std::endl;

   //4 * 2

   std::cout << multiply(4, 2) << std::endl;

   //-8 * 2

   std::cout << multiply(-8, 2) << std::endl;

   //0*1

   std::cout << multiply(0, 1) << std::endl;

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика