tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Нужно написать программу на
Нужно написать программу на с++, которая будет решать введенные в нее производные, например 2x^5 = 10x^4, cosx = - sinx, вычислять ответ производной не нужно.
LUKARIN
3 26.09.2019 17:10
0
Ответы
1234567890825
21.08.2020 16:18
//Microsoft (R) C/C++ Optimizing Compiler Version 19.00.23506 for x64
#include <iostream>
#include <string>
#include <vector>
#include <utility>
int main()
{
std::vector<std::pair<std::string, std::string>> deriv_sheet = {
std::make_pair("2x^5", "10x^4"),
std::make_pair("cosx", "-sinx")
};
std::string user_fx;
std::cin >> user_fx;
for (const auto& i : deriv_sheet )
if (i.first.compare(user_fx) == 0)
std::cout << i.second;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
юм123
30.06.2020 12:29
акрытом ящике находится 32 карандаша, некоторые из них синего цвета. Наугад вынимается один карандаш. Сообщение «этот карандаш – НЕ синий» несёт 4 бита информации. Сколько синих карандашей...
gfsfsdcxz
29.06.2020 12:59
13. Какая функция позволяет увидеть, как будет выглядеть документ, напечатанный на бумаге с использованием подключенного к компьютеру принтера?...
даша89194733164
29.06.2020 12:57
с решением информатике надо выполнить...
НюшаS12
29.06.2020 12:51
Почему принтер не печатает чёрным цветом при цветной печати? Пояснение: когда я выбираю цветную печать, то чёрный цвет не пропечатывается, только цветной, хотя раньше такого не было....
evgeha19821
22.12.2021 19:07
1) 19^10 переведите в 2-ю, 8-ю, 16-ю системы счисления; 2) 123^8 в Х^10; 3) 13^16 в Х^10...
Рита7373
22.12.2021 19:01
Створити нову таблицю у середовищі СУБД MS Access можна Виберіть одну або декілька відповідей: за до Звіту у режимі Конструктор за до Автотаблиці шляхом уведення даних...
2566409
22.12.2021 19:00
определите какому столбцу таблицы истинности функции F соответствует каждая из переменных x, y, z, w...
kornienko123456
22.12.2021 18:59
9. Скорость чтения ученика 8 класса составляет приблизительно 190 символов в минуту. Какой объем информации получит ученик, если он будет непрерывно читать в течение 20 минут?...
nam0
22.12.2021 18:59
Постройте таблицы истинности для следующих логических уравнений...
yuliya216
07.06.2019 19:40
Переведите в десятичную систему счисления следующие двоичные числа: 10101101, 111010011....
Популярные вопросы
Солеобразующие оксиды делятся на: А) основные Б) кислотные В) амфотерные Г) все...
1
7 сынып геометрия сызба бойынша есеп...
1
Школьный бассейн имеет объём 320 м3. Ширина бассейна 8м, глубина 2 м. Вычисли длину...
1
КАК РЕШИТЬ УРАВНЕНИЕ (Х НАДО НАЙТИ Х...
2
Точка Т – середина отрезка МР. Найдите координаты точки Р, если Т (-3;4) и М (-5;...
3
О чём Притча о мальчике и морских звёздах...
3
1.Вкажіть спільні риси цивілізації 16-17 століття: 1)держава верховной власник...
3
Кто из названных здесь людей совершает работу? 1) Лыжник на трассе соревнований...
3
Запишите уравнения возможных реакций мне...
1
Алгебра: 1) Построить график параболлы у= - х^2+1 . Исследовать получившуюся функцию....
2
#include <iostream>
#include <string>
#include <vector>
#include <utility>
int main()
{
std::vector<std::pair<std::string, std::string>> deriv_sheet = {
std::make_pair("2x^5", "10x^4"),
std::make_pair("cosx", "-sinx")
};
std::string user_fx;
std::cin >> user_fx;
for (const auto& i : deriv_sheet )
if (i.first.compare(user_fx) == 0)
std::cout << i.second;
}