tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Нужно написать программу
Нужно написать программу на паскаль ! нужно сделать треугольник вот такой --121-- -12321- 1234231 и тд
помогите1187
2 15.09.2019 19:50
0
Ответы
0katushka0
07.10.2020 18:09
Const n=4;
var i,j:integer;
begin
for i:=1 to n do
begin
for j:=1 to n-i do write('-');
for j:=1 to i do write(j);
for j:=i-1 downto 1 do write(j);
for j:=1 to n-i do write('-');
writeln;
end;
end.
Результат:
---1---
--121--
-12321-
1234321
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
КубайдулаФариза
17.04.2019 21:11
Дан целочисленный массив из 10 элементов. вывести на экран все его четные элементы, предварительно расположив их по убыванию методом пузырька...
nastyarapuntseozgwc2
17.04.2019 21:12
Дано: writeln (s: 6: 2); если s=113,18605, то на экране появится...
David13211
17.04.2019 21:16
Напишите программу, вычисляющую частное от деления двух целых неотрицательных чисел. входные данные дано два числа, длина каждого не превосходит 250 знаков, каждое число вводится...
юлия20043
17.04.2019 21:18
Сколько бит потребуется для кодирования одного пикселя изображения, если размер палитры 256 цветов? какова глубина цвета изображения, если используется чёрно-белая с оттенками...
КрендельЙА
13.08.2019 13:20
Напишите программу, которая определяет, является ли заданная строка правильным ip-адресом. на паскале...
nastya01102016
17.04.2021 19:58
Дайте определение объекта и модели Приведите примеры...
Vladisimus
17.04.2021 19:58
Потрібно відняти від нього 5, якщо воно менше ніж 12, збільшити в 2 рази, якщо воно не менше ніж 12, але менше ніж 40. Помножити його на 4, якщо воно не менше ніж 40. Виконайте...
Tanyams
17.04.2021 19:55
Что выведет программа, если на вход подать 573? num = int(input()) summa = 0 a = num % 10 b = num // 10 % 10 c = num // 100 % 10 summa = a + b + c print(summa)...
Вероника8381
17.04.2021 19:53
ответьте зачем нужны контроллеры...
larionxam
17.04.2021 19:51
)Різними мовамиHow many years do you need to put the amount of have in the bank to get the amount of UAH 1,000,000, if the bank has 7% per annum and the state imposes a tax...
Популярные вопросы
Ачто это за 1)чтобы из суммы двух чисел вычесть третье число,нужно из первого...
2
Что-то типа сочинения на тему честь в современном мире .с примерами и понятно...
1
Когнитивные,эмоциональные,мотивационные,инструментальные,трудности общения(обширно...
3
30 следующие предложения в present simple passive. example: 70 billion...
3
Написать сочинение про environmental problems...
3
Вы попали в ситуацию, когда необходимо оказать первую людям с переломами...
3
Выберети подходящюю форму глагола.yesterday afternoon kell. me about the...
3
Верны ли следующие суждения о социальных ролях? а) реакции, которые могут...
1
Что вы понимаете под кодированием информации...
2
Тест 15. форма политического устройства киевской руси: 1. вечевая республика....
3
var i,j:integer;
begin
for i:=1 to n do
begin
for j:=1 to n-i do write('-');
for j:=1 to i do write(j);
for j:=i-1 downto 1 do write(j);
for j:=1 to n-i do write('-');
writeln;
end;
end.
Результат:
---1---
--121--
-12321-
1234321