Нужно написать программу на pascal. программа должна выводить 20 случайных чисел от 1 до 26 и чтобы они не повторялись. числа должны сохранятся в массиве. заранее !

дильназ149 дильназ149    1   27.09.2019 04:20    5

Ответы
opvictor01p08056 opvictor01p08056  08.10.2020 22:03
Var a:array[1..20] of integer;
c,b,i,d: integer;
begin
c:=0;
b:=0;
for i:= 1 to 20 do
begin
a[i]:=random (1,26);
while (b <> 1) do
begin
for d:= 1 to i-1 do
if (a[i] = a[d]) then c:=1;
if (c = 1) then a[i]:=random (1,26) else b:=1;
c:=0;
end;
end;
for i:= 1 to 20 do
writeln(a[i]);
end.

P.S. Не уверен что правильно,т.к. не могу проверить программу в паскале
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика