Нужно написать программу на c++, которая будет рисовать полый квадрат из решеток(#) используя вложенный цикл.
Вводится одна переменная: длина стороны

fgdhdrbnh fgdhdrbnh    1   08.04.2020 12:32    5

Ответы
Asahimura Asahimura  23.08.2020 23:20

#include <iostream>

int main()

{

   int len, i, j;

   // Русский язык в консоли

   setlocale(LC_ALL, "Russian");

   std::cout << "Введите длину стороны: ";

   std::cin >> len;

   for (i = 0; i < len; i++)

   {

       for (j = 0; j < len; j++)

       {

           if ((j == 0) || (j == len - 1) || (i == 0) || (i == len - 1)) std::cout << "#";

           else std::cout << " ";

       }

       std::cout << std::endl;

   }

   

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика