Нужно написать программу, которая переводит десятичные числа в двоичные. на языке паскаль. !

kabulbekova01 kabulbekova01    3   27.09.2019 19:10    1

Ответы
avazjon2296 avazjon2296  21.08.2020 17:00

// PascalABC.NET 3.4.2, сборка 1785 от 06.09.2018

// Внимание! Если программа не работает, обновите версию!

begin

 var n := ReadInteger('Введите натуральное десятичное число:');

 var r: string := '';

 while n >= 2 do

   (r, n) := (n mod 2 + r, n shr 1);

 r := '1' + r;

 r.Println

end.

ПОКАЗАТЬ ОТВЕТЫ
geneanedel geneanedel  21.08.2020 17:00

Program l;

var

n: integer;

s: String;  

begin  

readln(n);  

while n>0 do begin  

insert(chr(48+n mod 2),s,1);  

n:=n div 2;  

end;  

writeln(s);  

end.


Нужно написать программу, которая переводит десятичные числа в двоичные. на языке паскаль. !
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика