нужна ваша решение на языке паскаль

На обработку поступает натуральное число, не превышающее 10^9. Нужно написать программу, которая выводит на экран сумму нечетных цифр числа, которые делятся на 3. Если в числе нет таких цифр, требуется на экран вывести «NO».

Айым200411 Айым200411    3   01.05.2020 19:41    12

Ответы
Maara Maara  14.10.2020 05:52

program z1;

var a,s: longint;

begin

write ('Введите число: ');

readln(a);

s:=0;

repeat

if (a mod 10 mod 2 = 1) and (a mod 10 mod 3 = 0) then s:=s+a mod 10;

a:=a div 10

until a=0;

if s = 0 then write('NO')

else writeln(s)

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика