Нужна с программированием в pascal. напишите программу на : "дано действительные числа a,b,c . если a> b> c , то числа оставить без изменений, в противоположном случае все числа заменить на их квадраты"

nikitafonarik05 nikitafonarik05    2   24.09.2019 01:10    0

Ответы
erkenova0909 erkenova0909  08.10.2020 13:48
PascalABC.NET 3.3.5, сборка 1660 от 20.04.2018
Внимание! Если программа не работает, обновите версию!

1. Современное решение

begin
  var (a,b,c):=ReadReal3;
  if (a>b) and (b>c) then else (a,b,c):=(a*a,b*b,c*c);
  Println(a,b,c)
end.

Пример
15.8 4.9 13
249.64 24.01 169

2. А так, увы, все еще учат писать во многих школах...

program Toska; 

var
  a,b,c:real;

begin
  Read(a,b,c);
  if not ((a>b) and (b>c)) then begin
    a:=a*a; b:=b*b; c:=c*c
    end;
  Writeln(a,' ',b,' ',c)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика