Нужна даю 40 болов
{Программа - диалог с компьютером.}
Program P1;
var Name:string;
Age:integer;
begin
write('Укажите Ваше имя: ');
readln(Name);
writeln('Здравствуйте, ',Name);
write('Укажите Ваш возраст: ');
readln(Age);
write('Через два года Вам будет: ',Age+2);
end.

Задание1:
1)Самостоятельно создать такую программу по образцу
2) ответить на во Что будет, если вместо имени ввести цифры?
Что будет, если на во о возрасте ввести букву?

3) Программа-диалог(Написать самостоятельно).
1)С у пользователя, в какой стране он планирует провести отпуск (завести переменную типа string, так как название страны – это слово. Например, Country:string;).
2)С какую сумму денег планируется потратить (завести переменную типа integer, так как сумма денег выражается числом. Например, Summa:integer;).
3)С сколько бонусных имеет клиент (здесь тоже нужна будет числовая переменная. Например, Bonus:integer;).
4)Вывести сообщение: «Страна – такая-то. Стоимость тура – такая-то.»
Стоимость тура можно рассчитать как
Summa–2*Bonus.Или как-нибудь по-другому использовать бонусы, на ваше усмотрение.

4)Рассчитать стоимость тура с учетом бонусных и вывести сообщение на экран.

{Вычислить периметр прямоугольника}
Program P2;
uses crt;
var a,b:integer;
begin
write('Укажите через пробел длины сторон прямоугольника: ');
readln(a,b);
writeln('P=',2*(a+b))
end.
Задание 2:
1)Самостоятельно написать программу, которая вычисляет площадь прямоугольника с заданными длинами сторон.
Задание 3:
Читать §3.2 учебника.

SABA30031 SABA30031    1   28.04.2020 12:22    2

Другие вопросы по теме Информатика