Ниже записана программа. получив на вход число x, она печатает два числа. укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 10. var x, l, m: integer; begin readln(x); l: =0; m: =0; while x > 0 do begin l: =l+1; if (m < x) and (x mod 2 = 1) then begin m: = (x mod 10) * 2; end; x: = x div 10; end; writeln(l); write(m); end.

equillirum equillirum    2   14.09.2019 03:00    0

Ответы
Finneas Finneas  07.10.2020 13:14
 L=2 -   количество цифр в числе Х
М=10 - (последняя цифра числа Х)*2>
                                                        (последняя цифра числа Х)=10:2=5
мах Х=95              ответ 95
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика