Необходимо составить программу, определяющую, какой координатной четверти принадлежит точка M(x,y).

Формат входных данных
С клавиатуры вводятся целые числа x и y (−231≤x,y≤231−1;x≠0;y≠0).

Формат выходных данных
Требуется вывести целое число, определяющее номер четверти координатной плоскости (1 — правая верхняя, 2 — левая верхняя, 3 — левая нижняя, 4 — правая нижняя).
входные данные
1 1
-4 -4
выходные данные
1
3

пмпсасрчвчврсв пмпсасрчвчврсв    3   27.11.2020 16:29    9

Ответы
sneginka2003 sneginka2003  27.12.2020 16:39

Объяснение:

#include <iostream>

using namespace std;

int main()

{

   int x, y; //(−231≤x,y≤231−1;x≠0;y≠0)

   cout<< "Введите X >= -231 & x!=0: "; cin>> x;

   cout<< "Введите y <=  230 & y!=0: "; cin>> y;

 

 if(x<-231 || x==0 || y>230 || y==0){

   cout << "Неправильно введены данные. Введите повторно:" << endl;

   cout<< "Введите X >= -231 & x!=0: "; cin>> x;

   cout<< "Введите y <=  230 & y!=0: "; cin>> y;

 }

 else{

   if(x>0 && y>0) cout << 1<<endl;

   if(x<0 && y>0) cout << 2<<endl;

   if(x<0 && y<0) cout << 3<<endl;

   if(x>0 && y<0) cout << 4<<endl;

 }

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика