Необходимо было написать программу, которая позволяет найти наименьшее
число, большее 500, кратное 17 и вывести его на экран.
Программист торопился и написал программу с ошибками. Укажите строки,
в которых допущены ошибки.
Var x: integer;
Begin
x:= 500;
Repeat o
x := х – 1;
Until x mod 17 <> 0
Writeln (х);
End.​

Даниил520393 Даниил520393    3   27.04.2020 00:16    21

Ответы
daniilbesperst daniilbesperst  13.10.2020 22:11

Var x: integer;

Begin

x:= 500;

Repeat o  //здесь непонятный символ o (должно быть: Repeat)

x := х – 1;   //здесь должно быть наоборот: к x надо прибавлять 1, так как надо найти число большее 500 (должно быть: x:= x + 1;)

Until x mod 17 <> 0   //здесь ошибка в том, что цикл repeat остановится когда число, деленное на 17, будет иметь остаток, а надо остановить тогда, когда при делении числа на 17 будет 0, то есть делится на 17 без остатка(должно быть: Until x mod 17 = 0;)

Writeln (х);

End.​

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика