НЕ ПОЛУЧАЕТСЯ РЕШИТЬ! Напишите программу, которая находит кота.
Пользователь вводит строки до тех пор, пока он не введёт «СТОП». Программа выводит номер строки, на которой впервые был упомянут кот (в том же смысле, что и в предыдущей задаче), или -1 (минус один), если кот не был упомянут.

Формат ввода
Несколько строк.
Сигнал остановки — строка «СТОП».

Формат вывода
Одно число — номер первой строчки, в которой появился кот, или -1, если кота нет.

Пример
Ввод
Как устроен типичный фрукт:
кожура;
мякоть;
косточки.
СТОП
Вывод;
3

247074 247074    3   26.10.2020 17:33    304

Ответы
Dasha555511111 Dasha555511111  25.11.2020 17:34

a = 0

b = 0

c = True

while True:

   v = input()

   a += 1

   if 'кот' in v.lower() and c:

       b = a

       c = False

   if 'стоп' in v.lower():

       break

if not b:

   b = -1

print(b)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика