tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Найдите произведение первых
Найдите произведение первых 10 элементов массива a состоящего из 50 элементов.
superguluagina
2 16.09.2019 17:10
0
Ответы
lebedevamilp00sr9
07.10.2020 20:09
//PascalABC.NET
//Версия 3.3, сборка 1611
begin
write('массив: ');
var a:=ArrRandom(50,-10,10).Println();
write('произведение 10: ',a.Slice(0,1,10).Aggregate(Real(1),(x,y)->x*y));
end.
ПОКАЗАТЬ ОТВЕТЫ
Миша2006443
07.10.2020 20:09
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!
begin
var a:= ArrRandom(50,1,15);a.Println;
Writeln(a.Where((v,i)-> i < 10).Aggregate(biginteger(1),(x,y)->x*y));
end.
Пример:
10 3 11 2 12 9 12 14 1 4 1 2 1 14 1 10 14 13 10 14 12 1 3 3 7 2 4 4 11 12 7 7 11 8 15 3 9 9 2 5 13 13 3 14 14 3 14 13 3 5
47900160
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
lizadobhliwdf
08.05.2019 12:01
Напишите программу вычисления выражения 2_а,б стр 173 1...
nurik01viper
08.05.2019 12:09
Найти наибольший делитель натурального чисел 12 18. на языке паскаль...
Dinez8
26.06.2019 01:40
Нужна программа для паскаля - реверс массива....
Sofff24
08.09.2019 09:00
Придумайте 3 предложения про символы и биты...
Nurs147
08.09.2019 09:00
Как установить закономерность вписать недостающие числа...
Alexandraananeva
21.06.2019 04:40
Сформировать одномерный массив, каждый элемент которого равен количеству нечетных отрицательных элементов соответствующей строки двумерного массива....
1MrFeNiKS1
21.06.2019 04:40
Даны две дроби a/b и c/d (a,b,c,d-натуральные числа). составить программу для умножения дроби на дробь. результат должен быть несократимой дробью. желательно через процедуру....
nemat110909oy85z9
21.06.2019 04:40
Ввести с клавиатуры координаты двух точек а и в на плоскости вещественный числа вычислить длину.программу нужно написать в паскале пример,как должно получиться введите координаты...
gffgfytdtdety
16.10.2020 20:21
Опиши два позволяющих уменьшить размер документа в формате bock...
aeraerororrrrea
16.10.2020 20:01
Составить логическую функцию и таблицу истинности, с краткими объяснениями...
Популярные вопросы
Решить пример (16-х) : 13 4/7=7/9 : 10 5/9 13 4/7 это дробь и 10 5/9...
3
Найдите значение выражения: 45+65=n, если n=47...
2
Вставьте, где надо, букву н. 1) скоше_ный; 2) рва_ный; 3) ране_ный в...
3
Напишите сочинение в художественном стиле на тему осень напишите...
2
Схема к предложению : люди, которые шли впереди, оставляли идущим вслед...
2
Краткое содержание виктора астафьева конь с розовой гривой на 2 страницы...
1
Спишите, вставляя подходящие предлоги: вникните всё это хорошенько. вмиг...
1
Сравни массы: а) 15т и 15305кг; б) 495кг и 5ц; в) 920г и 1кг; г) 29000кг...
3
Придумайте 2 тестовых вопроса по биологии тема - грибы. очеень ....
3
Как называется сказка живёт в поповом доме...
1
//Версия 3.3, сборка 1611
begin
write('массив: ');
var a:=ArrRandom(50,-10,10).Println();
write('произведение 10: ',a.Slice(0,1,10).Aggregate(Real(1),(x,y)->x*y));
end.
// Внимание! Если программа не работает, обновите версию!
begin
var a:= ArrRandom(50,1,15);a.Println;
Writeln(a.Where((v,i)-> i < 10).Aggregate(biginteger(1),(x,y)->x*y));
end.
Пример:
10 3 11 2 12 9 12 14 1 4 1 2 1 14 1 10 14 13 10 14 12 1 3 3 7 2 4 4 11 12 7 7 11 8 15 3 9 9 2 5 13 13 3 14 14 3 14 13 3 5
47900160