НАПИШИТЕ ПРОГУ НА ПИТОНЕ Напишите программу, которая ищет среди целых чисел, принадлежащих числовому отрезку [210 235; 210 300], числа, имеющие ровно четыре различных натуральных делителя, не считая единицы и самого числа. Для каждого найденного числа запишите эти четыре делителя в четыре соседних столбца на экране с новой строки. Делители в строке должны следовать в порядке возрастания.

Например, в диапазоне [10; 16] ровно четыре различных натуральных делителя имеет число 12, поэтому для этого диапазона вывод на экране должна содержать следующие значения:

2 3 4 6

dimabaklykov dimabaklykov    3   24.03.2021 19:09    3

Ответы
aydanxudieva14 aydanxudieva14  23.04.2021 19:19

for j in range(210235, 210301):

   count = []

   for i in range(2, j // 2 + 1):

       if j % i == 0:

           count.append(i)

           if len(count) > 4:

               break

   if len(count) == 4:

       print(" ".join(str(s) for s in count))

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика