Напишите программу, запрашивающую пин-код для банковской карты в виде четырехзначного числа. Считая, что в правильном пин-коде сумма первых двух цифр должна равняться сумме двух последних, выводя в случае ввода неправильного пин-кода соответствующее сообщение написать программу в Pascal ;(
pascal
Объяснение:
program pincode;
var
pin: integer;
begin
repeat
Write('Введите PIN-код: ');
ReadLn(pin);
until (length(inttostr(pin)) = 4);
if (pin div 1000 + (pin mod 1000) div 100) = ((pin mod 100) div 10 + pin mod 10)
then WriteLn('PIN-код верен!') else WriteLn('PIN-код неверен!');
end.