Напишите программу, выводящую все простые числа произвольной плследовательности. размер последовательности задает пользователь программы паскаль 7 классрешите

Dimo558 Dimo558    1   07.10.2019 02:20    3

Ответы
Мұғалімpvl Мұғалімpvl  10.10.2020 00:47

function isPrime(n: integer): boolean;

var d: integer;

begin

 d := 2;

 while (d <= Round(Sqrt(n))) and (n mod d <> 0) do d += 1;

 isPrime := d > Round(Sqrt(n))

end;

var N, a, i: integer;

begin

 Read(N);

 i := 1;

 while i<=N do

 begin

   Read(a);

   if isPrime(a) then Write(a, ' ');

   inc(i)

 end

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика