tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу выводящую
Напишите программу выводящую индекс наименьшего числа 3 9 1 3 5 8 5 3 6 7 6 5 4 6 1 81
rahmaevrail201
3 12.09.2019 07:50
0
Ответы
ladijka
07.10.2020 09:12
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=Arr(3,9,1,3,5,8,5,3,6,7,6,5,4,6,1,81); a.Println;
a.IndexesOf(t->t=a.Min).Select(t->t+1).Println
end.
Результат
3 9 1 3 5 8 5 3 6 7 6 5 4 6 1 81
3 15
ПОКАЗАТЬ ОТВЕТЫ
lana030935
07.10.2020 09:12
var i,n,k,min:integer;
a:array[1..1000] of integer;
begin
write('Write size array: '); readln(n);
for i:=1 to n do
read(a[i]);
min:=a[1];
for i:=1 to n do
if min>a[i]
then begin min:=a[i]; k:=i; end;
writeln(k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
ksa4
13.09.2019 13:40
Драйвер-это а)устройство компьютера б) вирус в) программа , обеспечивают работу устройства компьютера г) антивирусная программа имя файла...
Kmaj
13.09.2019 13:40
Вкаждой строке таблицы 7 ячеек. сколько в ней столбцов?...
shornikauvladi
13.09.2019 13:40
Программы bios записаны а)в микросхеме б)в оперативной памяти в)на жёстком диске...
200NaStYa002
13.09.2019 13:40
Вкаждой строке таблицы 15 ячеек. сколько в таблице записей?...
Kolibri98
13.09.2019 13:40
Дано трёхзначное число n определить является ли сумма первой и последней четным?...
dariamaniakova
28.10.2020 14:18
написать в Excele формулу....
tanyaanya200615
10.09.2020 02:07
Запишите последовательность не более чем из 5 команд что бы в результате ктр получится число 13...
алинка546
10.09.2020 02:16
написать код программы на языке Питона игра называется виселица...
skidan2002
10.09.2020 02:17
Запишите выражение в префиксной форме: (5*a)*(c-2*b)*d...
SofiLand854
10.09.2020 02:19
Что можно изменить В выбранном объекте: набор свойств, набор методов,значения свойств?...
Популярные вопросы
Один из катетов прямоугольного треугольника равен 6 см,а его гипотенуза...
1
Хрюша купил себе в буфете 9 ирисок а степаша 6 тут подошёл филя разделили...
2
(-3а²в)в третьей степени * (-7а в пятой степени b)² выражение...
3
Диагональ и сторона прямоугольника равны 13 и 5 см.найдите площадь этого...
3
Где нужно поставить запятую? ну вот ты уже и закончила ещё один год учёбы...
2
Решите в столбик: 102-(155,4: 14,8+2,1)*3,5...
2
Определите чему равно поясное время в г.санкт-петербурге,если в г.анадыре...
2
Один из смежных углов на 70 градусов больше другого. найдите оба угла...
3
Найдите значение выражения (4^-2*4^-7)/4^-6...
2
Человек ростом 1,7 метров стоит на расстоянии 9 метров от столба,на котором...
1
// Внимание! Если программа не работает, обновите версию!
begin
var a:=Arr(3,9,1,3,5,8,5,3,6,7,6,5,4,6,1,81); a.Println;
a.IndexesOf(t->t=a.Min).Select(t->t+1).Println
end.
Результат
3 9 1 3 5 8 5 3 6 7 6 5 4 6 1 81
3 15
a:array[1..1000] of integer;
begin
write('Write size array: '); readln(n);
for i:=1 to n do
read(a[i]);
min:=a[1];
for i:=1 to n do
if min>a[i]
then begin min:=a[i]; k:=i; end;
writeln(k);
end.