Напишите программу в с++, которая в последовательности натуральных чисел определяет минимальное число, оканчивающееся на 9. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Введённые числа не превышают по модулю 90 000. Если чисел, оканчивающееся на 9, нет, то вывести «NO».

cactuscus cactuscus    2   21.06.2020 05:51    5

Ответы
VasyaPupkin001 VasyaPupkin001  15.10.2020 14:35

#include <iostream>

#include<bits/stdc++.h>

using namespace std;

int main()

{

  int min = INT_MAX,n;

  cin>>n;

  while (n != 0)

  {

      if (n%10==9)

      {

          if (n < min)

           min = n;

      }

      cin>>n;

  }

 

  if (min == INT_MAX)

       cout<<"No"<<endl;

  else

       cout<<"min = "<<min<<endl;

 

 

 

   return 0;

}

Объяснение:


Напишите программу в с++, которая в последовательности натуральных чисел определяет минимальное числ
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика