Напишите программу в С++, которая в последовательности целых чисел определяет количество нечётных чисел, кратных 3. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности (завершающий 0 не учитывается) и количество нечётных чисел, кратных 3.Программа должна быть рабочей
#include <iostream>
#include <vector>
#include <ctime>
using namespace std;
int main() {
setlocale (LC_ALL, "Russian");
int counter = 0;
vector<int> numbers;
int buffer = 0;
do {
cin >> buffer;
numbers.push_back(buffer);
} while (buffer != 0||numbers.size()==1000);
numbers.pop_back();
for(int i = 0; i<numbers.size(); ++i) {
if(numbers[i]%3==0&&numbers[i]%2!=0) {
++counter;
}
}
cout << endl << "Колво нечётных чисел, кратных 3: " << counter;
cout << endl << "Всего чисел: " << numbers.size();
}