Напишите программу в паскале, которая высчитывает средний оценок (нужно чтобы в программу можно было вводить хоть сколько оценок).

sashachadaev sashachadaev    2   25.09.2019 23:20    1

Ответы
марина200008 марина200008  08.10.2020 19:31
Program p1;
var 
i,j,s:integer; 
r: double; 
a:array [1..9999] of integer;
begin
writeln('Запишите кол-во оценок');
read(j);
for i:=1 to j do 
begin 
writeln('Введите оценку #', i); 
read (a[i]); 
end;
for i:=1 to j do 
begin 
s:=a[i]+s; 
end; 
writeln('сумма оценок = ', s);
r:=s/j;
writeln('Средний бал = ',r);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика