Напишите программу в паскале. грузовой автомобиль выехал из одного города в другой со скоростью v1 км/ч через t ч в этом же направлении выехал легковой автомобиль со скоростью v2 км/ч. составить программу,определяющею,догонит легковой автомобиль грузовой через t1 х после своего выезда

Shamаn14 Shamаn14    3   30.06.2019 00:00    49

Ответы
раопп раопп  02.10.2020 15:43
 const     
v1 = 5; //Скорость грузовика     
v2 = 10;//Скорость легкового автомобиля     
t = 5;  //Задержка между выездом      

var   
t1 : integer; //Время, от выезда легкового авто  

begin 
readln (t1);   
if v1 * (t +t1) <= v2 * t1 then   
writeln ('Догонит')   
else    writeln ('Не догонит'); 
end.   

{ Уравнение зависимости координаты от времени 
x = xo + vt 
x0 = 0  

xg(t) = v1*(t+t1) 
xl(t) = v2*t1  

xl(t) >= xg(t) }
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика