Напишите программу в паскале, где дано натуральное число n и вычислить произведение первых n-сомножителей: а) 1*3/2*5/ б) 1*1/3*1/

slavka194 slavka194    1   23.08.2019 13:00    0

Ответы
настячччч настячччч  05.10.2020 14:39
Var
N,i,j:integer;
P:real;
Begin
i:=1;
j:=1;
P:=1;
WriteLn('Введите число N');
ReadLn(N);

Write('а:1');
While i<>n do
begin
j:=j+2;
i:=i+1;
P:=P*(j/i);
Write('*',j,'/',i);
end;
Write('=',P);

WriteLn();
Write('б:1');
i:=1;
j:=1;
P:=1;
While i<>n do
begin
j:=j+2;
i:=i+1;
P:=P/i;
Write('*1/',j);
end;
Write('=',P);

End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика