Напишите программу в pascal, которая проверяет делимость введенного числа с клавиатуры на 2,3,4,5

vuqaredilov2007 vuqaredilov2007    3   22.07.2019 15:20    6

Ответы
titova2017 titova2017  07.08.2020 12:20
Var a:integer;
  flag:boolean;
begin
  flag:=false;
  write('Введите число ');
  readln(a);
  if a mod 2 = 0 then  begin
    writeln('Число ',a,' делится на 2');
    flag:=true;
  end;
  if a mod 3 = 0 then begin
    writeln('Число ',a,' делится на 3');
    flag:=true;
  end;
  if a mod 4 = 0 then  begin
    writeln('Число ',a,' делится на 4');
    flag:=true;
  end;
  if a mod 5 = 0 then  begin
    writeln('Число ',a,' делится на 5');
    flag:=true;
  end;
  if not flag then writeln('Число ',a,' не делится на 2,3,4,5');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика