Напишите программу в которой одномерный массив на 10 элементов , нужно заполнить по формуле только четными значениями. выведите массив строчку. найдите количество значений лежащих в промежутке [6 до 20] (включительно 20). произведение тех, которые больше 10

Volodyaaaa Volodyaaaa    1   11.07.2019 14:30    1

Ответы
KristinaSagat55555 KristinaSagat55555  03.10.2020 01:18
Var A:array[1..10] of Integer;
i,N,k,l,j:integer;
begin
Readln(N);
For i:=1 to N do
A[i]:=Random(1,10);
For i:=1 to N do
Write(A[i],' ');
Writeln;
For i:=1 to N do
  If (A[i]>=6) and (A[i]<=20) then
  k:=k+1;
Writeln('количество значений лежащих в промежутке [6 до 20] ',k);
For i:=1 to N-1 do
  For j:=i+1 to N do
    If A[i]*A[j]>10 then
    l:=l+1;
Writeln('количество значений произведение которых больше 10',l);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика