Напишите программу решения любого квадратного уравнения. заранее!

катюха134567889000 катюха134567889000    3   21.06.2019 20:50    3

Ответы
Stasuyksuper06 Stasuyksuper06  17.07.2020 09:18
#include <stdio.h>
#include <math.h>

int main()
{
int a,b,c,D,x1,x2;
scanf ("%d %d %d", &a, &b, &c);
printf("%dx^2%dx%d=0\n", a,b,c);
printf("D=b^2-4ac=%d\n",b*b-4*a*c);
D=b*b-4*a*c;
if (D<0) printf("Net resh");
if (D==0) printf("x=-b/2a=%0.2f", -0.5*b/a);
if (D>0) {printf ("x1=(-b+sqrt(D))/2a=%0.2f \n", 0.5*(-b+sqrt(D))/a);          
              printf ("x2=(-b-sqrt(D))/2a=%0.2f \n", 0.5*(-b-sqrt(D))/a); }
return 0;
}   
ПОКАЗАТЬ ОТВЕТЫ
LOLLLAada LOLLLAada  17.07.2020 09:18
Java
исходник прикреплен (424 строк кода), основной плюс в том что этот алгоритм сокращает дроби, однако это бета, не совсем правильно иногда.
и еще корень не очень хорошо вычисляет
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика