Напишите программу, решающую любое квадратное уравнение. паскал

aptyp4ik228 aptyp4ik228    1   31.07.2019 09:20    2

Ответы
Kostya200601 Kostya200601  03.10.2020 18:31
Program kv_ur;
var a, b, c, d, x1,x2, x:real;
begin
read(a, b, c);
d:= sqr(b) - 4*a*c;
if d<0 then write('нет решений');
if d = 0 then
              begin
                 x:= -b/(2*a); write('один корень: ',x:5:2)
               end;
if d>0 then 
            begin
              x1:=(-b+sqrt(d))/(2*a);
              x2:=(-b-sqrt(d))/(2*a);
              write('два корня: ', 'x1=',x1:5:2,'x2=',x2:5:2)
            end
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика