tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу, при которой
Напишите программу, при которой можно подсчитать расходы на доставку мебели. исходные данные для расчета – номер этажа и информация о наличии и типе лифта (грузовой или обычный). c++
vi600081
2 27.09.2019 01:30
9
Ответы
Щкх
08.10.2020 21:37
Надеюсь без ошибок. Цену за отдельные аспекты назначте сами:
#include stdlib.h
#include <iostream>
using namespace std;
int main() {
setlocale(LC_ALL, "Russian");
int floor;
char lift, type0;
double price_floor;
double price_elevator;
double price_type;
double total_price;
bool elevator;
cout << "Введите номер этажа: ";
cin >> floor;
if (floor == 1 || floor <= 3) price_floor=1;
if (floor <= 6 && floor > 3) price_floor=2;
if (floor <= 9 && floor > 6) price_floor=3;
else if price_floor=4;
cout << "Имеется ли в вашем помещении лифт? "; //ответ + или -
cin >> lift;
switch (lift) {
case '+':
price_elevator=1;
elevator=true;
break;
case '-':
price_elevator=2;
break;
}
if (elevator) {
cout << "Грузоподъемный? ";
cin >> type0;
switch (type0) {
case '+':
price_type=1
break;
case '-':
price_type=2;
break;
}
}
else if cout <<"\n";
cout <<"\n";
total_price=price_elevator + price_floor + price_type;
cout << "Конечная цена: " << total_price <<endl;
system ("pause");
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
dashkevich672
29.10.2019 18:08
Составить программу на паскале....
anya190804
29.10.2019 17:59
Нужно сделать программу по паскаль, 40 . на картинке. ...
arsen7076ovwzre
21.10.2021 21:40
Вычислите значение выражения 9E16 – 9416. В ответе запишите вычисленное значение в десятичной системе счисления. Для выполнения задания 1 необходимо: 1. Перевести...
JaneAubakirova
21.10.2021 19:39
Командалық интерфейстің жұмыс жасау алгоритмін...
KrystallBlack
21.10.2021 19:27
4) Выполните вычисления: 1) 11000112+1110112 2) F78A16 – EDF 16 быстреее...
Andreyp2881
26.06.2019 10:50
Умоляю, написать алгоритм и программу,ну или что-то одно,по . дан двумерный массив ,состоящий из 10 строк и 5 столбцов.с клавиатуры вводится целое число n .найти...
bulyginaap08na1
26.06.2019 11:00
Даны вещественные x, y, z. вычислить в паскале а, если а=(sqr(x)+3*y-sqrt(z))/(y*sin(z)+exp(abs(...
taylakova090820
26.06.2019 11:00
Какое расширение имеют файлы, сохраняемые в powerpoint 2010 на диск? (отметьте один правильный вариант ответа.) вариант 1 *.pdf вариант 2 *.pptx вариант 3 *.xml...
закладчик
26.06.2019 11:10
Брошюра содержит 4 страницы, на каждой из которых в среднем по 50 строки из 32 символов каждая. сколько кбайт составляет информационный объем текстового файла с...
supervitalik15
26.06.2019 11:10
Сколько раз будет вызываться функция f при подсчете f(15)? самый первый вызов тоже считается. например при подсчете f(1) функция будет вызвана 1 раз. , с решением...
Популярные вопросы
Напишите первые четыре числакратные числу3...
3
Отметь словосочетаниния ехал издалека б) быстро одевался в)...
3
Скласти речення зі словами кобзар-кобзар...
1
Как пугачев пытается убедить гринева что он царь(капитанская...
3
Як перекладається gleich bringe ich ihnen die speisen. warten...
2
Какие грамматические ошибки здес ? . на встречу писателем пришли...
3
Как вы понимаете выражения носить в сердце ,мне по плечу?...
1
Настоящее имя французская карикатуриста эффеля...
3
Сказка о царе салтане как царевна лебедь обращается к гвидону...
1
Как вы думаете, почему первый алфавит был здан именно в финикии...
3
#include stdlib.h
#include <iostream>
using namespace std;
int main() {
setlocale(LC_ALL, "Russian");
int floor;
char lift, type0;
double price_floor;
double price_elevator;
double price_type;
double total_price;
bool elevator;
cout << "Введите номер этажа: ";
cin >> floor;
if (floor == 1 || floor <= 3) price_floor=1;
if (floor <= 6 && floor > 3) price_floor=2;
if (floor <= 9 && floor > 6) price_floor=3;
else if price_floor=4;
cout << "Имеется ли в вашем помещении лифт? "; //ответ + или -
cin >> lift;
switch (lift) {
case '+':
price_elevator=1;
elevator=true;
break;
case '-':
price_elevator=2;
break;
}
if (elevator) {
cout << "Грузоподъемный? ";
cin >> type0;
switch (type0) {
case '+':
price_type=1
break;
case '-':
price_type=2;
break;
}
}
else if cout <<"\n";
cout <<"\n";
total_price=price_elevator + price_floor + price_type;
cout << "Конечная цена: " << total_price <<endl;
system ("pause");
return 0;
}