tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу (pascal)
Напишите программу (pascal) найти сумму вводимых с клавиатуры чисел, которые отрицательные.
saschatuba
3 23.08.2019 10:10
1
Ответы
romamil
05.10.2020 14:24
Program n1;
var sum,a: integer;
begin
sum:=0;
repeat
readln(a);
if a<0 then sum:=sum+a;
until (a=0);
writeln(sum);
end.
ПОКАЗАТЬ ОТВЕТЫ
megalolka21
05.10.2020 14:24
// PascalABC.NET 3.2, сборка 1385 от 14.02.2017
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('Сумма отрицательных чисел равна ',
ReadSeqRealWhile('Ввод завершайте нулём:',x->x<>0).Where(x->x<0).Sum)
end.
Пример
Ввод завершайте нулём: 2.5 -4 -6.25 5.143 11 -8 0
Сумма отрицательных чисел равна -18.25
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
berry91819
25.08.2019 18:20
Запишиет 32-битовый ip-адрес в виде четырёх десятичных чисел, разделённых точками: 1)11001100100110001011111001000111 2)11011110110000111010001000110010...
choika64
25.08.2019 18:20
Чуть-чуть преобразовать код qbasic, нужно сюда как-то вставить проверку того, что a b, и четырёхзначное ли число. вот само : ввести с клавиатуры два четырёхзначных числа. если первое...
я2двойшник
25.08.2019 18:20
:написать программу, получающую с клавиатуры целое число и определяющую, верно ли, что цифры расположены в порядке возрастания. написать программу, получающую с клавиатуры целое...
yayy6uytuy6
25.08.2019 18:30
Двухцветное изображение на экране содержит 64 × 256 точек. определить минимальный объем памяти, необходимый для хранения этого изображения в кбайтах. )?...
Emmaasakura
25.08.2019 18:30
Какие вам известны формы представления зависимостей между величинами?...
katyamineeva02
25.08.2019 18:40
)реализовать проверку минимального введенного значения с клавиатуры , вывести на экран консольного вывода...
Qwerfcsfvfw
25.08.2019 18:40
Вывести на экран все трехзначные натуральные числа, сумма цифр которых не превосходит заданное пользователем (введенное с клавиатуры) число. pascal abc для 8 класса функцией или...
александра7896
25.08.2019 18:40
Спрограммированием! 1.из массива р, содержащего 10 элементов, сформировать массив т по правилу: a. т(к)=к*р(к), где к – чётные, т(к)=р(к)/к, где к – нечётные. 2. в массиве, содержащем...
KateSved
25.08.2019 18:40
Вычислить y=a+b+c , применив: а) - процедуру ввода данных; - процедуру вычисления y; - процедуру вывода результата; - переменные; pascal abc...
260807098978
25.08.2019 18:50
Считая, что каждый символ кодируется одним байтом, определите, чему равен информационный объем следующего высказывания жан-жака руссо: тысячи путей ведут к заблуждению, к истине...
Популярные вопросы
Задание 4. Скажите, какая форма глагола – Present Simple или Present Progressive...
3
Тіло на пружині здійснює три коливання за секунду. Максимальне відхилення тіла...
3
Транспортуйте у тональність ре мажор та підпишіть ступені....
2
Які хвощі поширені в Україні ? Індикатором чого в ґрунті є поява хвощів на городі...
2
Сравнить Канаду и США (учебник п.57-58 и карты) по плану: 1 В какой части материка...
2
Задание 2. Из текста выписать предложения обособленными обстоятельствами, деепричастными...
3
Осуществите превращения: 1) O2 - H2O - O2 - Al2O3 2) H2O2 - O2 - SO2 - SO3 3)...
3
1.Знайдіть знаменник геометричної прогресії (bn):2;6...2.Визначте п ятий член...
1
Як ви розумієте українське прислів’я: «Ремесло пити та їсти не а само дає...
2
Якої довжини потрібно взяти дріт з площею поперечного перерізу 0,5 мм квадратних,...
3
var sum,a: integer;
begin
sum:=0;
repeat
readln(a);
if a<0 then sum:=sum+a;
until (a=0);
writeln(sum);
end.
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('Сумма отрицательных чисел равна ',
ReadSeqRealWhile('Ввод завершайте нулём:',x->x<>0).Where(x->x<0).Sum)
end.
Пример
Ввод завершайте нулём: 2.5 -4 -6.25 5.143 11 -8 0
Сумма отрицательных чисел равна -18.25