Напишите программу определяющую количество максимальных чисел в массиве. массив состоит из 10 чисел

8Евген8 8Евген8    1   20.11.2019 09:35    0

Ответы
srednenorm srednenorm  10.10.2020 14:31

На языке Паскаль:

const

  n = 10;  

var

   i, a, max, count: integer;

begin

max = -32768 ;

count := 0;

writeln('МАссив:');

for i := 1 to n do

   begin

   read(a);

 if a > max  

   then  

       begin

       max := a;

       count := 1;

     end;

   else

   if a = max

   then

       inc(count)

   end;

   writeln('Count max = ', count);

end.

ПОКАЗАТЬ ОТВЕТЫ
спирина1 спирина1  10.10.2020 14:31

begin

 var a := ArrRandom(10, 1, 9);

 a.Println;

 Println('Кол-во чисел, равных max:',

     a.FindAll(p -> p = a.Max).Count)

end.


Напишите программу определяющую количество максимальных чисел в массиве. массив состоит из 10 чисел
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика

Популярные вопросы