Напишите программу на языке паскаль , которая будет делииь пирог на равные части по весу. ( масса пирога/кол во учеников ) Если кол во учеников = 0 , то должно выйти сообщение " 0 учеников в классе не может быть "

СНЕЖНАЯКОРОЛЕВА11 СНЕЖНАЯКОРОЛЕВА11    1   15.04.2021 11:03    9

Ответы
Диана090980 Диана090980  15.05.2021 12:05

var

 m, d :integer;

 part : double;

begin

 writeln('Масса пирога =');

 readln(m);

 writeln('количество учеников =');

 readln(d);

 if d > 0 then begin

   part := m/d;

   writeln('Вес каждой части пирога = ', part:2:2)

 end

 else

   writeln('0 учеников в классе не может быть');

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика