Напишите программу на языке паскаль для нахождение количества цифр в записи положительного целого числа x.

альбинка28 альбинка28    3   28.05.2019 15:40    0

Ответы
лиза2740 лиза2740  01.10.2020 13:42
Program ololo;
var a,b:integer;
begin
read(a);
if a = 0 then begin write(1); exit; end;
while a <> 0 do
begin
  inc(b);
  a := a div 10;
end;
write(b);
end.
ПОКАЗАТЬ ОТВЕТЫ
nosia nosia  01.10.2020 13:42
Вот так гораздо проще.

var s:string;
begin
readln(s);
writeln(length(s));
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика