tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу на языке
Напишите программу на языке pascal дано: натуральное число -n выяснить с цикла repeat является ли оно простым (то есть делится на 1 и на само себя)
mixrasp2002
1 31.08.2019 15:30
0
Ответы
элина332
06.10.2020 08:01
Var
i, n: integer;
begin
i := 1;
read(n);
repeat
i := i + 1;
if(n mod i = 0) and (n <> i) or (n = 1) then
begin
write('Число ', n, ' не является простым');
exit;
end;
until i = trunc(sqrt(n)) + 1;
write('Число ', n, ' является простым');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
lerikonusheva
16.06.2019 23:20
Какой информационный объем имеет файл, содержащий черно-белое графическое изображение 400 х 300 пикселей?...
Кукарику12
16.06.2019 23:20
Сколько килобайт составляет сообщение, содержащее 12 288 бит?...
Linaa631
28.08.2019 00:50
Написати програму, що за довжинами сторін трикутника визначає який він (рівнобедрений, рівносторонній чи довільний)./написать программу, по длинам сторон треугольника...
maria3317
21.12.2020 13:22
Дана таблица Счет к оплате . Определите формат ячеек1. D4:D10...
ЕвгешаК2003
21.12.2020 13:21
Составить алгоритм в виде блок схемы для вычисления следующего уравннния: S=2+4+6+...+236...
molniablack
21.12.2020 13:21
Моделирование процессов в электронных таблицах. Урок 2 редактирование графических изображений создания чертежей и трехмерных моделей сжатие документов для хранения информации...
AENabatov
16.09.2019 02:00
Переведите данное число из десятичной системы счисления в двоичную ,восьмеричную и шестнадцатеричную системы счисления а) 273(10) б) 661(10) в) 156,25(10) г)797,5(10)...
гуманитарийеп
16.09.2019 02:00
Перевести данное число в десятичную систему счисления а) 1100000000(2) б) 1101011111(2) в)1011001101,00011(2) г) 1011110100,011(2) д)10,17,2(8) е) 111,в(16)...
MarySilverstone
16.09.2019 02:00
Логическое выражение и результат представить в виде схемы и таблицы истинности: а) (x& y+z)& y+z б)a& ((b+c)+(b& c))+a...
новенькая10
06.06.2019 17:30
Размер массива и сам массив вводится с клавиатуры. найдите сумму элементов, удволетворяющих условию: остаток от деления на 3 равен 2....
Популярные вопросы
Сын есемнің әр сапасына 1 сөйлемнен құрастыр перевод: На каждое качество...
3
даю!! Видеоматериалды мұқият қарап, сұрақтарға жауап бер/Внимательно...
1
Алгебра ТРЕБУЕТСЯ АЛГЕБРА КОМЕК КЕРЕК...
1
Задание 2 Вспомните ситуации, когда в вашей семье проявилисьперечисленные...
1
Составьте простой план предложенного текста[2] 2 Изложите подробно...
1
Решите с чертежам и пояснением только первую задачу....
2
Дано: a ⃗(-5;7),b ⃗(7;-7), d ⃗=a ⃗-1/7 b ⃗. Найдите: а) координаты...
3
Найдите значение произведения (586–589)...
1
3. В параллелограмме ABCD утол А равен 60°. Высота BE делит сторону...
2
Отметьте сходства и различия.Обязательно!И только про царевну молодую...
3
i, n: integer;
begin
i := 1;
read(n);
repeat
i := i + 1;
if(n mod i = 0) and (n <> i) or (n = 1) then
begin
write('Число ', n, ' не является простым');
exit;
end;
until i = trunc(sqrt(n)) + 1;
write('Число ', n, ' является простым');
end.