Напишите программу на С++, которая заменяет в символьной строке все буквы a на буквы b (латинские, строчные). Решение с комментариями к
каждой строке кода. Комментарии должны пояснять, что происходит в каждой строке программы, для чего она нужна и т.п.

Входные данные
Входная строка содержит символы латинского алфавита, как строчные, так и заглавные.

Выходные данные
Программа должна заменить во всей строке строчные буквы a на буквы b и вывести в первой строке получившуюся символьную строку, а во второй – количество выполненных замен.

Примеры
входные данные
aabbccabadef
выходные данные
ccbbbdef
4

Шаригул Шаригул    3   21.04.2020 12:21    9

Ответы
dizelist7 dizelist7  13.10.2020 14:07

#include <stdio.h>

#include <locale.h>

#include <string.h>

#include <stdlib.h>

//Замена

#define a 'a'

#define b 'b'

//Размер строки

#define n 255

int main(){

setlocale(LC_ALL, "rus");

char s[n];

printf("\n >> Введите строку:\n << ");

fgets(s, n, stdin);

for (int i = 0; i < strlen(s); i++)

 if (s[i] == a)

 s[i] = b;

printf("\n >> Результат:\n >> ");

fputs(s, stdout);

system("pause>>void");

return 0;

}

Объяснение:так?

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика