Напишите программу на Python, которая бы вычисляла нумерологическое число (складываются числа даты рождения, до тех пор, пока не получится число от 1 до 9, допустим 23.01.2001 = 2 + 3 + 0 + 1 + 2 + 0 + 0 + 3 = 11 = 1 + 1 = 2. Нумерологическое число = 2.

marinka713 marinka713    2   14.06.2021 23:34    3

Ответы
Velievtim2000 Velievtim2000  15.07.2021 00:35

date=input()

numb=0

while not 0<numb<10:

   numb=0

   for i in date:

       if i.isdigit():

           numb+=int(i)

   date=str(numb)

print(numb)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика