Напишите программу на паскале. дан массив положительных и отрицательных чисел. вычислить сумму положительных и произведение отрицательных чисел. а[1..10]

Eldarval Eldarval    1   28.06.2019 14:10    2

Ответы
jhdjshshdh jhdjshshdh  02.10.2020 14:05
Const m=10;
var
a:array[1..m] of integer;
i,sum,proz:integer;
begin
sum:=0;
proz:=1;
for i:=1 to m do
begin
read(a[i]);
if a[i]>0 then
sum:=sum+a[i]
else
ifa[i]<0 then
proz:=proz*a[i];
end;
writeln('Сумма положительных чисел= ',sum,' Произведение отрицательных чисел= ',proz);end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика