Напишите программу на паскале.дан целочисленный квадратный массив 10x10.найти сумму максимальных элементов из каждой строки.предпологается, что в каждой строке такой элемент единственный

KINGMe KINGMe    2   29.05.2019 19:20    2

Ответы
DixonVeit DixonVeit  29.06.2020 01:43

var
  a : array [1..10] of longint;
  i,j,max,ans : longint;
begin
  for i:=1 to 10 do
    begin
      max:=-maxlongint;
      for j:=1 to 10 do
        begin
          read(a[i]);
          if a[i]>max then max:=a[i];
        end;
      ans:=ans+max;
      writeln;
     end;
  writeln(ans);
end.

И этот массив не квадратный. Такие массивы называют двумерными массивами.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика